<html>
<head>
<style><!--
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
font-size: 12pt;
font-family:Calibri
}
--></style></head>
<body class='hmmessage'><div dir='ltr'>It's all being done from localhost. everything is stored on my desktop at /var/www/ <br><br>As to <span dir="ltr">apt-cache search apache2 | grep php, this is what I got.<br><br>garrett@mint-desktop ~ $ apt-cache search apache2 | grep php<br><br>libapache2-mod-php5 - server-side, HTML-embedded scripting language (Apache 2 module)<br>php5-cgi - server-side, HTML-embedded scripting language (CGI binary)<br>libapache2-mod-php5filter - server-side, HTML-embedded scripting language (apache 2 filter module)<br>libapache2-mod-suphp - Apache2 module to run php scripts with the owner permissions<br>php5-fpm - server-side, HTML-embedded scripting language (FPM-CGI binary)<br></span><br><div><div id="SkyDrivePlaceholder"></div><hr id="stopSpelling">From: wes@the-wes.com<br>Date: Thu, 28 Feb 2013 11:50:55 -0800<br>To: chugalug@chugalug.org<br>Subject: Re: [Chugalug] LAMP problem<br><br><div dir="ltr">what's the URL to the html file? is it possible it's using a hostname other than "localhost" and that is causing different behavior between the two examples?<div><br></div><div>-wes</div></div>

<div class="ecxgmail_extra"><br><br><div class="ecxgmail_quote">On Thu, Feb 28, 2013 at 11:39 AM, Garrett Gaston <span dir="ltr"><<a href="mailto:garrett85@hotmail.com" target="_blank">garrett85@hotmail.com</a>></span> wrote:<br>

<blockquote class="ecxgmail_quote" style="border-left:1px #ccc solid;padding-left:1ex;">


<div><div dir="ltr">I'M trying to learn a little php but my learning as been halted by some strange behavior when executing my html/php files. Within my html documents I am attaching them to php files via: <br><br><form action="somefile.php" method="post"><br>

<br>When the html file executes the form, the browser downloads the somefile.php file as if I were a picture or song I was downloading from a website rather than executing and displaying the php page in the browser. Executing phpinfo() from the browser via 'localhost/phptest.php' is working just fine. This problem is only occurring when a php script is called to be executed from an html file within the browser. Also note that I have tried this in two browsers with the same result.<br>

<br>I've removed php5 and apache2 and re-installed both of them and I'M still getting the same result.<br><br>Here's the info from /var/log/apache2/error.log<br><br><blockquote>[Thu Feb 28 12:45:35 2013] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.5 with Suhosin-Patch configured -- resuming normal operations<br>

</blockquote><br>Any ideas. I've hit a brick wall here and I can't continue my php book until I get this resolved.<br>                                          </div></div>
<br>_______________________________________________<br>
Chugalug mailing list<br>
<a href="mailto:Chugalug@chugalug.org">Chugalug@chugalug.org</a><br>
<a href="http://chugalug.org/cgi-bin/mailman/listinfo/chugalug" target="_blank">http://chugalug.org/cgi-bin/mailman/listinfo/chugalug</a><br>
<br></blockquote></div><br></div>
<br>_______________________________________________
Chugalug mailing list
Chugalug@chugalug.org
http://chugalug.org/cgi-bin/mailman/listinfo/chugalug</div>                                         </div></body>
</html>