[Chugalug] Need a CentOS Networking Buff...

Joe Freeman joe at netbyjoe.com
Sat Mar 29 19:20:51 UTC 2014


Try this-

echo "ifup eth0:0" >> /etc/rc.local
On Mar 29, 2014 1:43 PM, "David White" <dwrudy at gmail.com> wrote:

> Evidently my question is one for the ages, since no one on ServerFault and
> anyone in Linode's IRC support channel has been answered it (successfully),
> nor anyone on Freenode's #centos has attempted to answer it.
>
> I'm having trouble setting up a 2nd (virtual) interface on my CentOS 6.x
> VPS. Everything works, except that whenever I reboot, the 2nd IP address
> doesn't come up. However, simply running "ifup eth0:0" after a reboot
> causes the 2nd IP to come up without an issue. You can view how I have the
> interfaces configured on my question on Server Fault from a couple days ago
> here:
> http://serverfault.com/questions/584525/starting-a-virtual-network-interface
>
> Since that question, the only changes I've made to the 2nd interface
> (eth0:0)'s config file is: I took out the Gateway, I took out the IPv6
> stuff, and I took out the "Type" directive ("Ethernet")
>
> I've also tried, today, to rename both the file (ifcfg-eth0:1), AND the
> interface defined within the file (DEVICE="eth0:1") to no avail. On the
> 2nd, new, IP addy's config file, I've also tried changing ONBOOT="yes" to
> ONPARENT="yes" which also hasn't worked.
>
> What could I be missing?
>
> --
> David White
> Founder & CEO
>
> *Develop CENTS *
> Computing, Equipping, Networking, Training & Supporting
> Nonprofit Organizations Worldwide
> http://developcents.com
> 423-693-4234
>
> _______________________________________________
> Chugalug mailing list
> Chugalug at chugalug.org
> http://chugalug.org/cgi-bin/mailman/listinfo/chugalug
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://chugalug.org/pipermail/chugalug/attachments/20140329/6ad42fe0/attachment-0001.html>


More information about the Chugalug mailing list