[Chugalug] TimeMachine on Ubuntu

Eric Wolf ebwolf at gmail.com
Sun Jun 9 19:05:45 UTC 2013


I was using an iomega SAN device which worked perfectly for Time Machine
which worked great until I added a second drive. The SAN kept thinking
there was a problem with my second drive in RAID1. And since the iomega
needs to erase both drives to get RAID1 back, it's not a great situation.
So I've been trying to get my FreeNAS 8.3.1 server to work with Time
Machine on my Macs. The web UI makes it seem like it's point-and-click. But
the unRTFM method doesn't seem to work. So I followed a few different
howtos on the web with little more luck. I can make Samba/CIFS shares that
show up in Finder. But nothing shows up in Time Machine.

I don't really have any data on FreeNAS yet. I've migrated everything to an
external 4TB drive while I get this squared away. And I wouldn't mind being
able to run other stuff on my NAS box. It's a Core i5-2500K with 32GB of
RAM - way overkill for just FreeNAS and FreeNAS isn't delivering on
ease-of-use.

Dipping a toe in the waters, I decided to try setting up netatalk and avahi
on my Ubuntu 12.10 workstation. I followed this guide online:

http://d43.me/blog/1660/concisest-guide-to-setting-up-time-machine-server-on-ubuntu-server-12-04/

I created a /opt/tardis directory that I chmod'd 777 since I wasn't given
clear instructions on how to set permissions. The share shows up in Time
Machine but when I try to connect, I get an error on the Mac and then the
afp daemon crashes on Ubuntu.

Anyone else have any luck with this?

-Eric

P.S. Yes, I made a post to CHUGALUG that involves three different flavors
of Unix! How's that for on-topic.

-=--=---=----=----=---=--=-=--=---=----=---=--=-=-
Eric B. Wolf                           720-334-7734
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://chugalug.org/pipermail/chugalug/attachments/20130609/102f580e/attachment.html>


More information about the Chugalug mailing list