[Chugalug] Help building ancient app...

DaWorm daworm at gmail.com
Mon Jan 7 14:55:09 UTC 2013


On Sun, Jan 6, 2013 at 8:49 PM, Sean Brewer <seabre986 at gmail.com> wrote:

> GCC on Ubuntu 12.04 is much newer I believe.. Do gcc -v, and I think it
> should give you the 4.7 release. The latest GCC patch for your app
> appears to be for the 4.4 series. You need to do something like this. I
> haven't tried it, so YMMV.
>
> Install GCC 4.4 and friends:
>
> $ sudo apt-get install gcc-4.4 g++-4.4
>
> Follow instructions here with additional instructions below:
> http://askubuntu.com/a/26518
>
> We want to be switching between 4.4 and 4.7, so instead of 4.3 and 4.4 in
> those instructions use 4.4 and 4.7
>
> Switch to GCC 4.4 compiler as shown in instructions in given link, then
> attempt to build. Make sure to do qmake clean, make clean, and all that
> before attempting to build again.
>

This sounds like it might very well be the answer.  Would it be best to
install the gcc 4.4 compiler, or figure out the appropriate patch to make
it work with the 4.7 compiler?

All this is on a laptop at home, so it will be this evening before I can
look at it.

Thanks for the help, I'll let you know how it goes (and if it works,
whether it was worth it, in case there are any other aspiring woodworkers
out there who might want a special purpose CAD program).

Jeff.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://chugalug.org/pipermail/chugalug/attachments/20130107/68477078/attachment-0001.html>


More information about the Chugalug mailing list