[Chugalug] LAMP problem

wes wes at the-wes.com
Thu Feb 28 19:50:55 UTC 2013


what's the URL to the html file? is it possible it's using a hostname other
than "localhost" and that is causing different behavior between the two
examples?

-wes


On Thu, Feb 28, 2013 at 11:39 AM, Garrett Gaston <garrett85 at hotmail.com>wrote:

> I'M trying to learn a little php but my learning as been halted by some
> strange behavior when executing my html/php files. Within my html documents
> I am attaching them to php files via:
>
> <form action="somefile.php" method="post">
>
> When the html file executes the form, the browser downloads the
> somefile.php file as if I were a picture or song I was downloading from a
> website rather than executing and displaying the php page in the browser.
> Executing phpinfo() from the browser via 'localhost/phptest.php' is working
> just fine. This problem is only occurring when a php script is called to be
> executed from an html file within the browser. Also note that I have tried
> this in two browsers with the same result.
>
> I've removed php5 and apache2 and re-installed both of them and I'M still
> getting the same result.
>
> Here's the info from /var/log/apache2/error.log
>
> [Thu Feb 28 12:45:35 2013] [notice] Apache/2.2.22 (Ubuntu)
> PHP/5.3.10-1ubuntu3.5 with Suhosin-Patch configured -- resuming normal
> operations
>
>
> Any ideas. I've hit a brick wall here and I can't continue my php book
> until I get this resolved.
>
> _______________________________________________
> Chugalug mailing list
> Chugalug at chugalug.org
> http://chugalug.org/cgi-bin/mailman/listinfo/chugalug
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://chugalug.org/pipermail/chugalug/attachments/20130228/2f942086/attachment.html>


More information about the Chugalug mailing list